MENU
 
Home
Nieuwsbrief
GC in de media
SiteMap
 
 
Tips en Tricks
Excel
Word
Photoshop
PowerPoint
Surf Tips
Gmail
Android
iPad
Excel ClipTips
 
cursus Office 2016
Access
Excel
Outlook
PowerPoint
Word
 
cursus Office 2013
Excel
PowerPoint
Word
Nieuw in Excel 2013
Nieuw in Word 2013
Nieuw in PowerPoint 2013
 
cursus Office 2010
Access
Nieuw in Excel 2010
Excel automatiseren
Excel
OneNote
Outlook
PowerPoint
Word
 
cursus Office 2007
Access
Excel
Outlook
PowerPoint
Publisher
Visio
Word
 
cursus Office
2000-2002-2003-XP
Access
Excel
PowerPoint
Outlook
Word
 
cursus Photoshop
CC -3D
Animatie
CS6
CS5
CS4
CS2 - CS3
Lightroom 3
Elements 6
Mask Pro
Nik Collection
 
cursus Dreamweaver
CS3
 
cursus Illustrator
CS4
 
cursus Flash
CS4
 
cursus Fireworks
CS4
 
cursus Paint Shop Pro
X en X2
 
cursus Premiere
Elements 7-8
 
cursus Joomla
Joomla 1.5
 
Sociale Netwerk sites
Facebook
LinkedIn
Twitter
 
iPad
Apps
 
Diversen
Celtx
CSS
DropBox
Firefox 3.6
GIMP
Internet Explorer 9
LIME
Linux
OpenSUZE
PREZI
ProShow Producer
YouTube
 
cursus Google
Agenda
Analytics
Gmail
Zoeken
Picasa 3
SketchUp
Chrome
Street View
 
cursus Windows
Live Movie Maker
Windows 10
Windows 8
Windows 7
XP
Vista
 
cursus Office '97
Word
Excel
 
 

 

Tips Excel   go to : Index
       

Tip 069

   
Deze Tip werd geschreven door mezelf.
 
Gemiddelde afhankelijk van het aantal ingevulde cellen
Op vraag van Hilde, Gert, Luc en Stef leg ik je uit hoe je het gemiddelde berekent, afhankelijk van het aantal ingevulde cellen.
Klik hier om het bestand te downloaden.
 

Om het gemiddelde te berekenen van het aantal ingevude cellen hebben we twee mogelijkheden.

Ik zal beginnen met de meest "verstaanbare".
We maken de som van het "bereik", en delen dit door het aantal ingevulde cellen. Dit moet ons het gemiddelde geven. Toch?

Dus we gebruiken twee functies in de formule.
De functie SOM en de functie AANTAL.
De functie SOM berekent de som van het ingevulde bereik, wat had je anders gedacht.
De functie AANTAL telt het aantal cellen dat getallen bezit in het bereik.
En dat laatste is belangrijk: "het aantal cellen dat getallen bezit". Dus geen letters.

Louter ter informatie:
Wens je het aantal ingevulde cellen te berekenen, gebruik je de functie AANTALARG.
Deze telt alle cellen die niet leeg zijn, dus ook deze met letters.
Maar dit is hier niet van toepassing.
We moeten enkel het aantal cellen hebben, die voorzien zijn van getallen.

Dus we typen de formule =SOM(B1:B12)/AANTAL(B1:B12)
In menseltaal staat hier dus: de som van het bereik B1 tot en met B12, gedeeld door het aantal getallen in het bereik B1 tot en met B12.
Iedereen volgt?

Natuurlijk. Dit is makkelijk.
 
De meer ervaren Excel-gebruiker maakt echter gebruik van een matrix-formule.
In dit voorbeeld is dit niet echt nodig, maar wanneer je in de toekomst ingewikkelde formules wil gebruiken, zal je hiermee toch moeten leren werken.
In Tip 19 had Valentin je reeds een voorbeeld gegeven van een, toch wel ingewikkelde matrix-formule, dus veronderstel ik dat deze voor jullie geen probleem meer zijn.
 
Om het gemiddelde te berekenen van ingevulde cellen met een getal, door middel van een matrix-formule, gebruiken we volgende formule:
=GEMIDDELDE(ALS(B1:B12<>0; B1:B12;""))
 
Ik leg de even uit:
ALS(B1:B12<>0
Van elke cel in het bereik B2:I2 controleert Excel of de waarde niet nul is.
Is dit waar dan wordt de waarde overgenomen.
 

B1:B12;""
Is de waarde wel 0 dan vervangt Excel deze door “”.

 

Het resultaat van de ALS functie levert dan de volgende matrix op:
1245;1135;975;1485;1395;1265;"";"";1365;1025;1450;1950
dus:
januari;februari;maart;april;mei;juni;juli;augustus;september,oktober;november;december

of:
1245;1135;975;1485;1395;1265;niks;niks;1365;1025;1450;1950
 
of de matrix-formule in zijn geheel:
1245+1135+975+1485+1395+1265+1365+1025+1450+1950 gedeeld door het aantal getallen.
In dit geval dus 10.
Juli en Augustus hebben namelijk geen waarde.
 
Heel belangrijk!
Een matrix-formule sluit je steeds af door de toetsencombinatie Ctrl+Shift+Enter op je toetsenbord te klikken.
Dit plaatst deze formule automatisch rond accolades { }
 
Mocht je dit niet doen en gewoon de Enter-toets klikken, zou je volgende foutmelding krijgen:
Dus zie je dit, dan weet je wat je fout hebt gedaaan.
Hoef je niet opnieuw te beginnen hoor.
Plaats gewoon de cursor achteraan de formule in de formulebalk, en klik Ctrl+Shift+Enter
 
Ter informatie: GratisCursus.be denkt aan zijn cursisten, denk ook aan GratisCursus.be
 
Index
 

All courses now available in English:
www.swotster.com

copyright © 2012 - Swotster Ltd - Hong Kong - China