MENU
 
Home
Forums
Enquête
Nieuwsbrief
GC in de media
SiteMap
 
Tips en Tricks
Excel
Word
Photoshop
Gmail
Android
iPad
Excel ClipTips
 
cursus Office 2013
Nieuw in Excel 2013
Nieuw in Word 2013
Nieuw in PowerPoint 2013
 
cursus Office 2010
Access
Nieuw in Excel 2010
Excel automatiseren
Excel
OneNote
Outlook
PowerPoint
Word
 
cursus Office 2007
Access
Excel
Outlook
PowerPoint
Publisher
Visio
Word
 
cursus Office
2000-2002-2003-XP
Access
Excel
PowerPoint
Outlook
Word
 
cursus Photoshop
Animatie
CS6
CS5
CS4
CS2 - CS3
Lightroom 3
Elements 6
Mask Pro
 
cursus Dreamweaver
CS3
 
cursus Illustrator
CS4
 
cursus Flash
CS4
 
cursus Fireworks
CS4
 
cursus Paint Shop Pro
X en X2
 
cursus Premiere
Elements 7-8
 
cursus Joomla
Joomla 1.5
 
Sociale Netwerk sites
Facebook
LinkedIn
Twitter
 
iPad
Apps
 
Diversen
Celtx
CSS
DropBox
Firefox 3.6
GIMP
Internet Explorer 9
LIME
PREZI
ProShow Producer
YouTube
 
cursus Google
Agenda
Analytics
Gmail
Zoeken
Picasa 3
SketchUp
Chrome
Street View
 
cursus Windows
Live Movie Maker
Windows 7
XP
Vista
 
cursus Office '97
Word
Excel
 
 
Voeg deze site toe
aan je favorieten!

 

Tips Excel   go to : Index
       

Tip 110

   
Deze Tip werd geschreven door mezelf
 
Conditioneel opmaken van gegevens in grafiek - Deel 1

In deze tip toon ik jullie hoe je een grafiek kunt opmaken, afhankelijk van condities.
Bijvoorbeeld, afhankelijk van de cijfers in de tabel, wijzigt de opmaak van de gegevens in de grafiek.

Als voorbeeld heb ik een grafiek die me de gegevens in het rood weergeeft wanneer deze het minst verkocht zijn, en in het groen wanneer deze het meest verkocht zijn.
Wanneer er twee of meerdere getallen dezelfde waarde hebben, moet hij deze allen hetzelfde opmaken.
Zoals je kunt zien in onderstaande afbeelding, heb ik een grafiek die me groene kolom(men) weergeeft voor de best verkochte producten, en die me rode kolom(men) weergeeft voor de slechts verkochte producten.
Wijzig ik de gegevens in de tabel, dan wordt automatisch de opmaak van de kolommen in de grafiek aangepast.

Het voorbeeldbestand kan je hier downloaden.

 
Laat ik eerst al beginnen met de vraag, "kunnen we een grafiek opmaken met condities?".
Het antwoord is "Neen".
Dus moeten we een beetje vals spelen.
De truuk is:
De grafiek is helemaal niet gebaseerd op de tabel aan de linkerzijde, maar aan een onderliggende tabel.
Deze onderliggende tabel is gebaseerd op de tabel aan de linkerzijde, en geeft me het hoogste getal (kolom GROEN), het laagste getal (kolom ROOD), en indien aan geen van beide voorgaande voorwaarden is voldaan, komen de gegevens in de kolom ZWART te staan.
 

Laat ik eerst beginnen met het hoogste cijfer(s) uit de tabel te halen.
De formule hiervoor is:
=ALS(B2=MAX($B$2:$B$10);B2;0)
Ik leg deze even uit.

Als de inhoud van cel B2 het hoogste getal (B2=MAX) is in het bereik B2 tot B10 ($B$2:$B$10), dan geef je me de waarde uit cel B2, indien dat niet het geval is dan geef je me de waarde 0 (nul).
Ik maak de celreferenties van het bereik absoluut, omdat ik deze formule straks naar onder ga kopiëren.

 
Vervolgens kopieren we dus deze formule naar onder, door met de vulgreep te slepen.
Zoals je ziet in onderstaande afbeelding geeft hij ons netjes het hoogste getal uit de linker tabel.
 

Vervolgens gaan we het kleinste getal uit onze linker tabel halen.
Deze plaatsen we in de kolom ROOD.
Typ hiervoor volgende formule:
=ALS(EN(E2=0;B2=KLEINSTE($B$2:$B$10;1));B2;0)
Ik probeer deze even uit te leggen:

We gebruiken de functie ALS omdat hij gegevens conditioneel moet vergelijken.
We gebruiken de functie EN omdat hij meerdere controles moet uitvoeren.
En we gebruiken de functie KLEINSTE om ons het kleinste getal uit het bereik te tonen.

Dus in het eerste deel kijkt hij of de cel E2 gelijk is aan nul (E2=0;B2)
Als het waar is dan geeft hij een nul, is dit niet waar dan geeft hij de waarde uit cel B2.

In het tweede (=KLEINSTE($B$2:$B$10;1) deel gaat hij zoeken naar het kleinste getal in het bereik.
Mocht je de 1 achter het bereik in een 2 wijzigen, zou hij het op één na laagste cijfer weergeven.
Maar dit was even ter informatie.

Ook van dit bereik maken we een absoluut bereik, omdat we de formule naar onder gaan kopiëren.

 
Ook deze formule kopiëren we dus naar onder door te klikken en te slepen met de vulgreep.
 

Nu hebben we al een kolom met de hoogste getallen (GROEN) en de laagste getallen (ROOD), nu nog een met alle getallen die niet in een van de vorige kolommen thuis horen (ZWART).
Dit is makkelijk.
Dit is de waarde in cel B2 min de waarde in cel F2, min de waarde in cel E2.

Dus: =B2-F2-E2

 
Ook deze formule kopiëren we naar de onderliggende cellen.
 
In het tweede deel gaan we onze grafiek toevoegen
 
 
 
 
Index

All courses now available in English:
www.swotster.com

copyright © 2012 - Swotster Ltd - Hong Kong - China