MENU
 
Home
Nieuwsbrief
GC in de media
SiteMap
 
 
Tips en Tricks
Excel
Word
Photoshop
PowerPoint
Surf Tips
Gmail
Android
iPad
Excel ClipTips
 
cursus Office 2016
Access
Excel
Outlook
PowerPoint
Word
 
cursus Office 2013
Excel
PowerPoint
Word
Nieuw in Excel 2013
Nieuw in Word 2013
Nieuw in PowerPoint 2013
 
cursus Office 2010
Access
Nieuw in Excel 2010
Excel automatiseren
Excel
OneNote
Outlook
PowerPoint
Word
 
cursus Office 2007
Access
Excel
Outlook
PowerPoint
Publisher
Visio
Word
 
cursus Office
2000-2002-2003-XP
Access
Excel
PowerPoint
Outlook
Word
 
cursus Photoshop
CC -3D
Animatie
CS6
CS5
CS4
CS2 - CS3
Lightroom 3
Elements 6
Mask Pro
Nik Collection
 
cursus Dreamweaver
CS3
 
cursus Illustrator
CS4
 
cursus Flash
CS4
 
cursus Fireworks
CS4
 
cursus Paint Shop Pro
X en X2
 
cursus Premiere
Elements 7-8
 
cursus Joomla
Joomla 1.5
 
Sociale Netwerk sites
Facebook
LinkedIn
Twitter
 
iPad
Apps
 
Diversen
Celtx
CSS
DropBox
Firefox 3.6
GIMP
Internet Explorer 9
LIME
Linux
OpenSUZE
PREZI
ProShow Producer
YouTube
 
cursus Google
Agenda
Analytics
Gmail
Zoeken
Picasa 3
SketchUp
Chrome
Street View
 
cursus Windows
Live Movie Maker
Windows 10
Windows 8
Windows 7
XP
Vista
 
cursus Office '97
Word
Excel
 
 

 

Tips Excel   go to : Index
       

Tip 167

   
Deze Tip werd geschreven door mezelf
 

Aantal daadwerkelijk niet lege cellen

Op vraag van Christel, toon ik jullie een formule waarmee je het aantal niet lege cellen telt, maar wanneer deze voorzien zijn van een formule die me een blanco resultaat geven, deze niet worden meegeteld.
De vraag lijkt wat ingewikkeld, althans dat was deze toch voor mij, maar met een voorbeeld wordt het toch wat meer duidelijk.

Het voorbeeldbestand kun je hier downloaden.
Steun www. GratisCursus.be :
 
In onderstaand voorbeeld heb ik in het bereik A1:A10 van kolom A een aantal ingevulde cellen.
Wanneer ik de functie AANTALARG gebruik, om me het aantal niet lege cellen te geven, geeft deze me het resultaat 8. Toch zijn er maar 7 cellen die me een waarde geven.
 
Hoe komt dit?
Wel in cel A9 staat een formule die me een lege waarde geeft.
De waarde mag dan wel niks tonen, dus leeg zijn, de celinhoud is dat niet. Deze bevat een formule.
 
Hoe lossen we dit op, was de vraag van Christel.
Wel, hiervoor kunnen we gebruik maken van de functie SOMPRODUCT.
Meer bepaalt de formule =SOMPRODUCT(--(A1:A10<>"")).
Wat staat hier?
We beginnen met het dubbele minteken --, om de waarden "WAAR" en "NIET WAAR " te converteren naar eentjes en nulletjes in een matrixformule.
Vervolgens typen we het "bereik": A1:A10
En typen de tekens <>, dus kleiner dan en groter dan. Dit betekent dus "niet gelijk aan".
En tenslotte typen we twee dubbele aanhalingstekens "", wat staat voor blanco.
Dus heel dit deel <>"" wil zeggen 'is niet gelijk aan blanco'.
Klik Enter op je toetsenbord en je hebt de daadwerkelijk niet lege cellen.
 
Wijzig je de inhoud van cel A1 zodat de inhoud van cel A9 wijzigt in een niet lege cel, dan zal automatisch het aantal niet blanco cellen worden aangepast.
 
GratisCursus denkt aan jullie, denk aan GratisCursus
 
 
 
Index
 
 
 
 
 

All courses now available in English:
www.swotster.com

copyright © 2012 - Swotster Ltd - Hong Kong - China