MENU
 
Home
Nieuwsbrief
GC in de media
SiteMap
 
 
Tips en Tricks
Excel
Word
Photoshop
PowerPoint
Surf Tips
Gmail
Android
iPad
Excel ClipTips
 
cursus Office 2016
Access
Excel
Outlook
PowerPoint
Word
 
cursus Office 2013
Excel
PowerPoint
Word
Nieuw in Excel 2013
Nieuw in Word 2013
Nieuw in PowerPoint 2013
 
cursus Office 2010
Access
Nieuw in Excel 2010
Excel automatiseren
Excel
OneNote
Outlook
PowerPoint
Word
 
cursus Office 2007
Access
Excel
Outlook
PowerPoint
Publisher
Visio
Word
 
cursus Office
2000-2002-2003-XP
Access
Excel
PowerPoint
Outlook
Word
 
cursus Photoshop
CC -3D
Animatie
CS6
CS5
CS4
CS2 - CS3
Lightroom 3
Elements 6
Mask Pro
Nik Collection
 
cursus Dreamweaver
CS3
 
cursus Illustrator
CS4
 
cursus Flash
CS4
 
cursus Fireworks
CS4
 
cursus Paint Shop Pro
X en X2
 
cursus Premiere
Elements 7-8
 
cursus Joomla
Joomla 1.5
 
Sociale Netwerk sites
Facebook
LinkedIn
Twitter
 
iPad
Apps
 
Diversen
Celtx
CSS
DropBox
Firefox 3.6
GIMP
Internet Explorer 9
LIME
Linux
OpenSUZE
PREZI
ProShow Producer
YouTube
 
cursus Google
Agenda
Analytics
Gmail
Zoeken
Picasa 3
SketchUp
Chrome
Street View
 
cursus Windows
Live Movie Maker
Windows 10
Windows 8
Windows 7
XP
Vista
 
cursus Office '97
Word
Excel
 
 

 

Tips Excel   go to : Index
       

Tip 269

   
Excel Tip
 

 

RANG ALS

Jurgen wenst een formule om waarden te rangschikken per artikel en vroeg me of er hiervoor een functie bestaat zoals AANTAL.ALS, bv RANG.ALS
Wel Jurgen deze functie bestaat niet, maar ik heb hiervoor een oplossing gevonden.
Wens je het voorbeeldbestand, klik hier.

 
De formule die ik hiervoor gebruik is =SOMPRODUCT(--(C2=$C$2:$C$20);--(B2<$B$2:$B$20))+1
Ik probeer deze even uit te leggen:

Wat we moeten doen is de afdelingen eerst scheiden, vervolgens vergelijken en ten laatste optellen.
Hiervoor gebruiken we de functie SOMPRODUCT.
De functie SOMPRODUCT bestaat uit arrays, een array bestaat uit de waarden WAAR of NIET WAAR.
Met deze waarden kunnen we niet rekenen, dus moeten we deze eerst omzetten in nullen en enen.
Dit doen we door twee maal het min-teken te plaatsen voor de formule.

Vervolgens gaan we kijken of cel C2 gelijk is aan de inhoud van de hele kolom $C$2:$C$20.
Dit bereik moeten we absoluut maken omdat we de formule straks gaan kopiëren naar onder.

De tweede array moet deze nummers rangschikken. Ook deze array moet van de waarden WAAR of NIET WAAR nummers 0 en 1 maken, dus deze beginnen we ook met een dubbel min-teken
Vervolgens kijken we of B2 kleiner is dan andere waarden in deze kolom B$2:$B$20

En omdat we de waarden van de rangschikking willen beginnen op 1, en niet op nul, typen we +1 op het eind van de formule.

 
Wanneer we de formule doorvoeren naar de onderliggende cellen, worden de rangordes netjes weergegeven volgens de afdeling.
 
Ik hoop hiermee Jurgen zijn probleem te hebben opgelost.
 
GratisCursus.be denkt aan jullie.

Index
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

All courses now available in English:
www.swotster.com

copyright © 2012 - Swotster Ltd - Hong Kong - China